Kineviz 3.29.0 Release Notes Release Date: September 22, 2026 Kineviz and Kineviz Desktop include UI changes, performance upgrades and bug fixes. Numerous usability enhancements include a redesigned Toolbar, split Views and Project menu, Information panel, and Legend features. Gizmo layout and Annotate tools, social network analysis (SNA) algorithms, and workspace options are added. System prompt and UI enhancements provide clearer Agent interaction. In a Kineviz Online or Kineviz Desktop project, to access release notes, click the Kineviz logo at the bottom left, choose About, then click on the release tag. New Features 3.29.0 Usability Enhancements From the Edit Project dialog, either click Confirm to remain on the Project home page, or Confirm and Open to open the edited project. (GXR-4667) The project Toolbar is no longer contextual. A tool unavailable to the current graph or selection is simply grayed out. Information, Trace Neighbor, Quick Layout tools are redesigned. Two new tools (Annotate and Gizmo) are added. The Information, Expand, Add Node, and Add Edge panels are now dockable for crafting user-defined workspaces. (GXR-4652, GXR-4706) Tools are displayed by default in the following labeled sections, which wrap bottom to top as the browser window is resized: History: Undo / Redo, and a More… menu with Link, Video, and Image tools. Display: Take Screenshot, Show hidden nodes, Hide nodes, Annotate (new), Quick Info toggle, and the 3D-2D toggle. Arrange: Collect nodes, Explode Collections, Gizmo (new, Gizmo Settings (new), Pin/Release nodes, Force Layout toggle, Quick Layout menu. Edit: Add Node, Add Edge, Expand, Tag. Select: Select Visible, Inverse, Trace Neighbor (re-designed), Information (re-designed) Information panel is re-designed. (GXR-4675, GXR-4680) A selection of nodes or edges can be displayed, not just a single entity at a time. Navigate the list, select a node or edge to view/edit properties, view Neighbors, and the Graph represented in the selected elements. Style selected nodes (but not edges) separately from the styles applied in the Settings or Legend, and remove the special styling as needed. The new Gizmo tool provides on-canvas layout to move, rotate, or scale any selection of the graph in the X-, Y-, or Z- direction either directly on the canvas, or by clicking the new Gizmo settings tool to display the Gizmo tab on the Layout panel (rather than the controls available in the Geometric layout panel). (GXR-4635). The new Annotate tool lets you add and style text commentary, graphic callouts, and a title to the canvas. Annotations are saved in the view, and an annotated view can be captured as a .png screenshot. (GXR-4488) Improved Legend: For a Category with a label too long to display in full, a rollover tooltip shows the full label, and the number of selected and total nodes. (GXR-4712) A scrollbar is included to navigate numerous categories or relationships. GXR-4717) A category’s Style Setting > Icon tab includes an Auto-Pick Icons button. It uses the AI agent and gxr.agent.run() API call to auto-pick Category icons, bulk-filling missing icons across the full category list, while preserving existing choices. (GXR-4644) The Minimap is closed by default.(GXR-4688) The Fly Out navigation icon on the right edge centers the graph on the visible canvas (i.e the space not covered by open panels) (GXR-4643) The in-project Project / View menu now includes the standard project editing functions (Add to Favorites, Edit Project, Clone Project, Export Project, Protect from deletion , and Delete ) in addition to Create Project, a menu to switch to another project, and All Projects to return to the Projects home page. (GXR-4677) The Save As view dialog is redesigned and enhanced to show a view thumbnail and the number of nodes and edges. Users must enter a view name, and can enter a description, choose a view folder, and enable sharing through project access and/or a view link. (GXR-4697, GXR-4701) New settings in the Project > Settings panel A Theme Manager menu, to select from a variety of pre-configured themes (e.g. Kineviz, Japandi, Bauhaus, etc.). (GXR-4682). Under Advanced Settings, Show recent views on empty canvas, to either show or hide the list of views displayed when a project is opened. (GXR-4655). For CSV/Excel import by drag and drop or Import, a dialog now includes options to Import directly, in which every row in a table becomes a node with the column values as its properties, or to Create mapping, which loads the files to the CSV/Excel query interface and opens the Mapping Editor to create a mapping for the files. (GXR-4613) New SNA tab in the Algorithm panel for Social Network Analysis (SNA) Algorithms, including measures of Fragmentation, Frequency, Density, Closure, and overall Network Statistics. (GXR-3139) Agent Users can now respond to agent results via Accept / Reject buttons, not just by typing OK. (GXR_4709) A Retry button re-runs a prompt. (GXR_4722) Click the Agent panel’s text input to add the suggested ghost question (and note that clicking twice clears the text input). You must click Tab to submit the suggested question. (GXR_4723) System prompt is updated to prevent nodes stacking on top of each other after API-driven changes to the canvas (e.g. gxr.addNodes, gxr.queryToCanvas, gxr.randomGraph, etc). (GXR_4659) System prompt is updated so that URL fetch occurs through the backend proxy when a direct fetch fails. (GXR_4661) System prompt is updated and a skill added to load JSON files into KoreDB. (GXR_4663) The runTask sub-agent includes an expanded view and an added Open button to display the full transcript in one click. (GXR_4662) Performance Enhancements NA Administration, Security, Configuration, and Deployment Enhancements Users can hide Files and Text Editor extensions in the Settings > UI Configuration dialog. (GXR-4679) The Email Me checkbox is opt-in per deployment. (GXR-4715) Agent skills can be contributed to the Kineviz Marketplace. (GXR-4689) Kineviz API gxr.ask is used to configure AI models for extensions. gxr.llm and its injectGraphSchema option is deprecated_. (GXR-4686) gxr.agent.run(), used to auto-pick icons based on category settings and legend. It bulk fills missing icons across the full category list while preserving existing choices. Two additional options enable cheap text completion, or restricting the agent to reading the graph: tools?: string[] | false - allow-list; false or [] means no tools at all (pure text completion), and excludeTools?: string[] - deny-list, which wins over the allow-list. (GXR-4688) Bug Fixes NA Removed 3.29.0 Agent: checkpoint views removed (GXR-4707) gxr.llm() deprecated in favor of gxr.ask(). (GXR-4686) Extensions 3.29.0 The Kineviz extensions provided by default let you create Grove workbooks for reproducible workflows and manage and edit imported files. Extensions for custom solutions may also be available. To add (or remove) an extension on the left panel menu, go to the Project > Extensions tab, search for the extension, then click its star icon. Grove Observable-based javascript notebooks Files File management extension The Files panel sidebar is resizeable. (GXR-4695) Text Editor Text editor extension