Create and Manage Projects The Projects (or Home) page is your portal to: Create or import Kineviz projects, and optionally connect to an external or internal database. Review and edit existing projects, including shared projects, sandboxes and demos. Project Cards display project details and editing options. The Table icon at the top right lets you display a more compact project list. Create a Project You can create and configure a Kineviz project at any time. You can: create a new project manually create a project by prompting the built-in Kineviz Agent start from a pre-configured sandbox project. When you create a project, you can optionally connect it to an internal KoreDB database or one of several external databases. For details, see Connect a Database to Kineviz. Create a New Project To create a new project: Click New Project, at the top right of the Projects page. In the New Project dialog: Select the optional database connection (or skip connection): Click Empty Graph to automatically create an internal KoreDB. Click Your database to select an existing external database. The databases Kineviz supports are listed in the dropdown menu in Cypher, Gremlin, GQL/PGQL, or Other sections. To more easily locate the desired database, select the menu’s Grid view and either enter a search in the search bar, or click to display only the list for a section. Then click to select the database you want. Click Skip database below the Your database menu to create a project with no connected database. Without a database connection, you can import and model data in formats such as CSV, SQL and JSON, and import graph data via GXRF files, Snapshot archives, and more. Simply drag and drop files directly, or use the Kineviz Mapping Editor for initial graph modeling. If you select an external database, additional details needed to confirm connection to your database are displayed. You may also need to verify that your external database is running before trying to connect to it. Most database types require: Host (or IP) Port - a default is shown for most options. Database Username Password Database Name For GCP Spanner and Big Query property graphs, when you select the database type and click Confirm, a connection wizard guides you through a detailed secure deployment process which ends by opening the project. The Kineviz Database Proxy which securely connects Kineviz to various backend databases requires an API url. In Apply Template, either leave the default None, or select a template from the menu. Templates specify colors, icons and other UI configuration settings for easy re-use. Enter a descriptive Project Name in the text box. A name is automatically suggested; you will likely want to change it. Enter an optional project Description. You can add or edit this later if desired. Enter or select optional Tags that indicate the general topic or audience for the project. In Slug, enter an optional short name to be used in the project’s share link instead of its id. Use a name unique to the server of 3–64 characters with lowercase letters, numbers and hyphens only. The project card that will be displayed on the Projects page is updated as you enter details. Click Upload image to upload an optional thumbnail image to display on the card, or you can do it later. Click Create and Open to create the new project and open it, Create only to create the project and return to the Projects page, or Cancel to return to the Projects page without creating a project. Create a Project from a Prompt You can use the Kineviz Agent to create a project, locate and import data, and model the graph. To start a project with a prompt: On the projects home page, click the Start a project text box. Under Start a project with a prompt enter a project name and any details about what you want the project to accomplish. For hints about how to start, click the See some examples link below the prompt window. Click Create project The project opens, starting a chat in the Agent panel where you can specify the data and model and direct agentic exploration and visualization. Create a Project from a Sandbox A sandbox is a pre-configured project that can include a database connection, data views, styling templates, and any Kineviz extensions it uses. A project created from a sandbox is cloned and automatically opened. You can flag any of your existing projects as collaborative sandboxes for your specific use cases. For example, Kineviz provides in-app tutorials as Sandbox projects showing how to create and explore graph data, and communicate useful results. To create a project from a sandbox: On the projects home page, in the start a project area near the top, click From a sandbox. In the Start from a Sandbox dropdown, locate the sandbox. You can click the link at the bottom of the short list to display all the sandboxes available to your account. Click the card for the sandbox you want to copy (or click the Kineviz logo at the top to return to the Projects page without creating a new project.) The new project is created and opened, named Sandbox Name (n) (for example Books Sandbox (1). To re-name the project, choose Edit in the project split view menu at the top center of the canvas, and in the Edit Project dialog, enter the new name and click Confirm. A project created from a sandbox includes the database connection (if any), saved data views, UI configuration, and workspace configuration, Kineviz Notebooks, and Agent setup present in the sandbox. It is not itself a sandbox, so its project card or list does not display the blue flask icon. Work with Existing Projects All the projects existing in your account are displayed on the Kineviz home page. You can: Review projects in either a Card or Table (tabular list) format. Sort, search and filter Projects Click a project card or list item to open it. Jump back in to any of the last four recently opened projects. Add to or remove from Favorites Edit project details including name, description, tags, database connection, and sandbox status. Import a project Clone a project Export a Project Transfer ownership of a project Delete a project, unless it is protected from deletion. Review Projects On the projects page, projects are displayed in either a Card or Table (tabular list). You can click to open a project from either one. Both formats display information and tools to search, sort, review and configure a project. Project configuration can also be changed within an open project using the split Project / View menu at the top center of the canvas. Project Card Display A project Card is created for each project available to your account. A project card includes: A project image area with: A window to upload an optional image (card only). You can add or update it at any time, either within an open project, or using the project’s Edit menu. A star icon at the top right. Click it to set the project as a Favorite. A database badge at the bottom left showing the connected database (if any). An optional workflow badge (e.g. Agentic, Manual, etc) at the top right. A Project title A blue flask icon on pre-configured sandbox projects, and a green sharing icon on projects shared with you. A lock icon for projects that have been protected from deletion. The project description (Card only). The date the project was Created, and the date it was last Opened. For a Shared project, the Author. A settings icon, for a contextual dropdown menu of options to edit, share, export, or delete the project: Add to Favorites / Remove from Favorites. Edit project name, template, and/ or database type. Clone to create a duplicate of the project, including its views and internal database (if any). Export Project, to export the entire project, downloading it to your system as a .graphxrproject file. UI Configuration, to configure user interface elements the sharing user sees, for example, to limit features to only those needed for collaboration. Share Project to share the project with another user of the Kineviz account. Open Views to open views and generate iframe code that you can include in a report, proposal, or other communication. Enable / Disable Sharing to toggle the project between sharing and non-shared status. Transfer ownership, to transfer control of a project to another user. Allow or Protect from Deletion, to set a flag to prevent project deletion. Delete (trash can), to delete the project, its saved views, and internal graph database (but not data in an external connected graph database), if deletion is allowed. Project Table Display The Table display option is a more compact table or list. It includes most of the information and editing options available on the cards, as well as the same project search and filter options as in the Card display. The Table display includes: Compact, sortable lists of projects in separate My Projects and Shared Projects sections. Sandbox and lock icons are displayed with the project Name The settings dropdown menu for project editing options, located in the Actions column on the far right. Project image, tags, and description are only shown on the card or in the Edit Project dialog. Sort, Search, and Filter Projects To display only specific projects, you can use pre-defined sorting and filters, and/or the project search bar. Sort displayed projects In the Card display, use the dropdown sort menu to sort projects by: * Project name * Date created * Date last opened * Author In the Table display, simply click arrows next to a table heading to sort in ascending or descending order. Search for a specific project To display a specific project, enter all or part of a name, author, tag, or description in the Search bar at the top of the page. The search operates on currently displayed projects, and a search term is applied until you remove it. Filter projects Pre-defined filters appear on the left menu bar. Default filters include: All Projects, projects you’ve created, shared projects, and sandbox projects. Favorites, projects where you’ve clicked the star icon on the project card or Add to Favorites on the edit menu in a table view. Shared with me, projects other users have shared with you. My sandboxes, sandbox projects available to your account. Additional pre-defined filters can be chosen from the Add Filter menu, including: User-defined project Tag (e.g. Beginner, Intermediate, etc.) Date last Opened, displaying a slider control to filter projects from the previous 7 to 90 days. Date Created, displaying a slider control to filter projects from the previous 7 to 90 days. Database Type Project Authors Projects with Deletion protection Open a Project To open a project, simply click its card or list item. To open a recent project, you can either: Search for projects by Date last opened Click All Projects to display a Jump back in section with cards for the last four project you opened. The small cards show how long ago each project was last opened. Click a card to open the project. + NOTE: Project sorting and filters do not apply to the Jump back in section. + + When you first open a project, its canvas is empty. To import graph data onto the canvas, you can load a view from the list of recent data views already saved in a project (if any), import an external file by drag and drop, or query the connected database via a no-code query. + Edit a Project The Edit Project dialog lets you change project details at any time. Open it by selecting Edit on either: the settings menu on the project home page, or the split Project / View menu in any open project. To edit project details and configuration: In a project’s settings dropdown menu, select Edit. In the Edit Project dialog you can: Enter a new Project Name, optional Description, and Slug (short name used in a project’s share link) Click to select different Tags to be displayed on the project card. Enter different database connection details. Apply or reapply a styling template. Flag a project as a sandbox, and specify who it can be shared with. You can flag any existing project as a sandbox, which adds it to My Sandboxes and makes it available for other users to copy and extend. In the Who can open this sandbox dropdown, the default is Signed in - anyone on this server. The other options are Public - anyone with the link, or Restricted - only people you share it with Click Confirm. Changes take effect immediately on the project page and in the open project: A changed project name and configuration details are immediately updated When you flag the project as a sandbox: A blue flask icon appears on the project card or list. The count in My Sandboxes in the project navigation menu is updated. Clone a Project Cloning a project duplicates its description, data, views, and styling. A default name is applied that you can change before creating the clone. To clone a project: In the project’s settings dropdown menu, select Clone. In the Clone Project dialog, optionally enter a new name. Click Confirm A duplicate of the project is created (including any Kineviz Notebook files), and the project is opened automatically. Export a Project You can export an entire project as a .gxrproject file downloaded to your system. This is useful for archiving projects, moving projects offline for later use. To export a project: In the project’s settings dropdown menu, select Export project. Messages indicate successful export and download of the named .gxrproject file. Import a Project Any project exported as a .gxrproject file can be imported into your account. A .gxrproject file includes all project views, the internal database, and the template and other styling in effect when the project was exported. To import a project: In the Projects home page, click the New Project dropdown arrow, and select Import Project. In the Import project dialog, click to locate and select the .gxrproject file (or drag and drop the file). Click Import. When the project is imported successfully, either click Open to open it, or Cancel to return to the Projects home page. The imported project is named as Project name (imported). To re-name the project, choose Edit either on the project card or list or in the project split view menu. In the Edit Project dialog, enter the new name and click Confirm Share a Project You can directly share a project with other Kineviz users. To collaborate with those who don’t have a Kineviz account, you can share individual views securely via iframe. To share a project: In the project’s settings dropdown menu, select Enable Share Now select Share Project Select a sharing user from the dropdown menu, and click Invite. Share Project Views You can select project views and generate iframe code that you can share in an email, report, proposal, or other communication. To share project views: In the project’s settings dropdown menu, select Enable Share. Now select Open Views to see the list of project views. In the list of project views, either click: Open view to open the view in a separate browser window. Generate iframe code, copying it to the clipboard for sharing with an external user. Transfer Project Ownership You can transfer ownership of a project to another Kineviz user, and choose whether or not you will retain access. To transfer project ownership: In the project’s settings dropdown menu, select Transfer ownership. In the dialog, choose the user from the dropdown menu. Optionally de-select the Keep me as a collaborator checkbox (which is selected by default). Click Transfer. Delete a Project You can delete a project from your account. If it is protected from deletion, a lock icon appears on the project cadd or list item, and you must remove protection first. To delete a project: If the project is protected, in the project’s settings dropdown menu, select Allow deletion. Once the update occurs, select Delete Project.