Export Data By exporting data from a project, or exporting an entire project, you can provide data that can be imported to another application or user, or archive views and the data store at key points during an analytic workflow. You can export all or part of a project at any time, including: The entire project. Project Views as a CSV or Excel archive, or .graphxr file. A .graphxrsnapshots view archive from the Snapshots title bar. All or part of a Table of the data on the canvas as a CSV or Excel file. The internal graph database and / or its schema from the Data Store panel. A data mapping created in the Mapping Editor as a JSON file using the Save Schema button. When you Clear data, exit a project or log out of Kineviz, saved data views and the internal database persist, but the graph on the project canvas and any snapshot views are deleted. To avoid losing work, save a view and/or export data when you come to a point in an exploration that you may want to re-visit. Export a Project Exporting a project downloads a .graphxrproject file to your local system. It includes all of the project’s UI and template settings, managed files, AI Agent history, views, and connected internal datastore. To export an entire project: In an open project you can either: Click the Export menu at the top right of the project window, and choose Export Project. Open the canvas Project menu and select Export Project. From the Projects home page, locate the project, open its settings menu, and select Export Project. The .graphxrproject file is downloaded to your system. You can then import it into any Kineviz or Kineviz Desktop account. Export Project Views You can export the current view on the canvas, as well as any saved view or current Snapshot archive. You can also export all saved views in one step from the Data Store subpanel. The information retained varies with the exported file type: Export as a .graphxr file retains the graph data as well as its 3D layout and perspective, whether or not it is saved before export. Consider saving a view before exporting it. This provides a descriptive view name to search for when importing the view. A view that’s saved before export is named with the Project name, View name, and .graphxr extension. For example: Demo_Crime.graphxr A view that’s not saved before export is named with the_Project_ name, (nth view saved from the project), and .graphxr. For example, Demo (1).graphxr Export as a CSV or Excel archive creates in a collection of flat files, one for each category and relationship. A file for a category includes node IDs, properties and their values. A file for a relationship includes the node source and target IDs, and any edge properties and their values. Export all saved views in one step from the Data Store subpanel. Once exported, you can import the views to another (or the same) project by drag and drop. Export the current view You can export the current view on the canvas using either: The canvas View menu, to export a .graphxr file The Export menu at the top right of the project canvas, to export a CSV or Excel archive, or .graphxr file. You can also export a static .png or or SVG screenshot of the current view from the Export menu. To export the current view on the canvas: Optionally, save the view, either as the existing view or a new view. Use one of the following: Open the canvas View dropdown menu, and choose Export. This downloads a .graphxr file. Open the Export dropdown menu at the top right of the canvas, and choose from: CSV to export a CSV archive with a .zip extension: ProjectName_ViewName.zip Excel to export an Excel archive with an .xlsx extension: ProjectName_ViewName.xlsx .graphxr to export a .graphxr file: ProjectName_ViewName(or number).graphxr. The file name appears in the Downloads tab of your Chrome browser window. Export a saved view You can export any saved view displayed in the Project > Views panel. To export a saved view: Open the Project > Views panel, and locate the view. Click the view’s View actions (3 dot) menu, and choose Export. The view .graphxr file is downloaded to your system. Export all saved views in one step The Export All Views option in the Project > Data Store subpanel exports all your saved views in one step. Views are exported one by one as individual .graphxr files. To export all saved views in one step: Open the Project > Data Store subpanel. In the Utilities section at the top, click Export All Views. For each view, a .graphxr file is exported, labeled with the ProjectName and saved ViewName. Export a Snapshot view archive Snapshots provide a way to save a set of up to 10 views locally. For exploratory analysis, snapshots make it easier to return quickly to specific branching points in a single investigative session. Snapshot views are saved locally, not to the server. To save the snapshots you’ve created during a project session, you must export them as a .graphxrsnapshots view archive before you exit the project. In a .graphxrsnapshot archive, view metadata is preserved when you re-load the views. by default, the Snapshots feature is hidden. To display it, open the Project > Settings panel and Canvas section, and click the *Show Snapshot checkbox. To export a snapshot view archive: Optionally, open the Snapshots window to review, annotate, or delete the snapshots created during your project session. Click the Save Snapshots button. You can click the export icon in the Snapshots title bar to export a snapshot archive without opening the window or reviewing its views. Export data from a table For any single category or relationship, you can export some or all of data that’s visible on the canvas as a table of nodes or edges and their property values. You can: The exported file receives a default name based on the category or relationship label: Label(YYYY-MM-DD).xlsx or .csv For example, Image(2026-05-02).csv contains a table of Image nodes exported on 2026-05-02. To export data from a table Select data on the canvas using any method, or de-select all data for tables of all the data. Open the Table panel. The Table > Category subpanel is open by default. It shows all the categories present in the current selection on the canvas (or all visible data if no selection has been made). Open the Table > Relationship subpanel to see all the relationships present, and click a relationship bubble to see its table. Select a table to export by clicking its category or relationship bubble: Optionally, enter table and/or column search terms to find the table rows you want to export. Click the checkbox in the table heading to Select All rows, or click individual row checkboxes to export only the rows returned by the search (if any). Click the More Actions dropdown menu, and choose Export Selected as Excel or Export Selected as CSV. A file with the selected table rows is downloaded to your system. Export the internal graph database The internal KoreDB graph database is managed from the Data Store panel. To export the internal graph database: Open the Project > Data Store panel. In the Data Store section, select the Database Name for the instance you want to export (there may only be one default option). At the bottom of the section, click Export Database. The exported file is named DatabaseName__export (number).db. For example, the second time you export the default database, the filename is default_export(2).db. Export the graph database schema The Data Store panel lets you display and export the current schema for the connected graph database as a .json file. To export the graph database schema: Open the Project > Data Store panel. In the Database section, select the Database Name for the instance you want to export (there may only be one default option). In the Utilities section at the top of the panel, click Schema. In the Schema_ window, click Export. The exported .json file is named graphxr-schema(number).json_. The number indicates the number of times a schema has been exported from that project. Export a data mapping A data mapping is a graph schema for a single table that you define in the Kineviz Mapping Editor. A mapping is saved to the server and is available on the Mapping menu in the Query > CSV and Query > SQL subpanels. From there, it can be applied, edited, and saved as a new mapping. A CSV or SQL mapping is available to sharing users of the project and persists in a project until you delete the mapping (or the project). You may want to export a mapping to include it in a different project, or to maintain an archive on your local system. To export a mapping: Open the Query > CSV or Query > SQL subpanel. In the Mapping menu, select the mapping to export, and click Edit. Click Edit to display the Mapping Editor window. Click the Export Schema icon at the top left. The mapping is exported to your local system as a .json file named MappingName.json.