Share Projects and Views In the multi-user Kineviz platform, a project’s saved views can be shared with other users. You can: Share an entire project. Share individual project views through a Share link or iFrame. Although it is usually best to Share a project or its views, you can Export an entire project to your local system as a .graphxrproject file, or one or more views as a .graphxr file, CSV or Excel archive, or Snapshot archive (.graphxrsnapshots). Exporting is most useful for archiving views and projects for later use or reference. However, it is also useful for transferring downloaded files to a different Kineviz or Kineviz Desktop project by drag and drop, using Import in the Project > Data Store subpanel, or for an entire project, the Import Project button on the Projects home page. Share a Project You can share any Kineviz project, and set sharing privileges as a Viewer, Editor or Creator. Once a project is shared, all its saved views are available to the invited users. Single-user Kineviz Desktop does not support project sharing. You can, however, share views one at a time via a view link. Grant Shared Access to a Project You must first enable project sharing, then grant shared access to other users of your Kineviz account. To share a project and its data views: Go to the Projects (Home) page, and locate the project you want to share. Open the project settings menu, and choose Enable Share. The menu changes to DisableShare, and additional Share Project, Open Views, and UIConfiguration menu items appear. Once project sharing is enabled on the home page, in the open project the canvas Project menu includes Share Project. Optionally, you can choose UIConfiguration to review and edit the user interface presented in the project. Click visibility icons to set UI elements to: Public - Enabled on the project and for shared users. Project - Enabled on the Project Off - Disabled (i.e. not shown in the project UI) In an open project, UIConfiguration is also available in the Project > Settings panel. Click Back or the Kineviz logo at the upper left to return to the home page. Now open the project Settings menu, and select Share Project. Select sharing privileges from the dropdown menu (Viewer, Editor or Creator). Select a Kineviz user email from the dropdown menu, and click Invite. Access a Shared Project Once you are invited to share a Kineviz project, it appears on your Projects page in the Shared Projects area. You can also click Shared with me in the project sidebar menu. Click the shared project tile (or list) to open the project and load a view. Share a single View Once you save a view you can: Share its url with either internal or external collaborators using the View menu or the Project > Views panel. Embed a shared Kineviz view as an iframe on another web page, using the dropdown list of the project’s saved views on the Projects (Home) page. Use a Share link From the view menu or Project > Views tab you can obtain a Share link for an individual view. You can send the link to anyone, even if they do not have a Kineviz login. Optionally, you can protect the view by requiring login or a password. To generate a Share link for a view: Enter the project, and locate the view you want to share. You can either: Use the canvas View dropdown menu to select the view and load it to the canvas, then choose Share. Open the Project > Views tab, locate the view in the card or list, click its View actions_ menu (the 3 dots at the right), and choose Share view. In the Share dialog, you can optionally set authentication, database access, and/or password protection. Click the Require authentication checkbox to require the sharing user to log in to Kineviz. Click the Allow database access checkbox to allow the sharing user to query the database from the shared view. Enter a Password in the text box, and click Save. You can now click Copy Link and paste it into an email to the user. To open the view, the login status and password (if any) will be required. Send the password in a separate email. When authenticated, the project opens with the single view available. Embed a view as an iFrame You can obtain code for iFrame embedding from a project’s list of shared views. Single-user Kineviz Desktop does not support project sharing or generating iframe code. To embed a view as an iFrame: In the Project (Home) page, open the project’s settings menu, and choose Open Views. Locate the view and click Generate iframe code at the right. A message indicates that the code has been copied to the clipboard. Paste the iframe embed code into the html for the web page of your choice. This code should be similar to the following example: <iframe src="https://cloud.kineviz.com/share/6a9cdd8ba391a67f5002b0da/KGC2026_sec10k_Views/6a9cdd8ba391a67f5002b0db" frameborder="0" width="100%" height="100%"> </iframe>