The Project Workspace The Kineviz project workspace is designed to enable users to work seamlessly with the visualized graph and its connected database. It provides a virtual 3D or 2D canvas for visual display, navigation, and layout of the graph, and a configurable set of features and tools for data management and exploratory analytics. Functions and tools are organized in panels, a legend, a toolbar, dropdown menus, and a live status bar, as follows: Kineviz logo at the top right, to return to the projects home page. Combined Query/Search bar at the top left of the browser window, to either enter a no-code Query on the connected graph database, or a Search of property values in the database or on the project canvas. Split Project / View menus, at the top center of the browser window: Project menu, to create, open, and manage projects within any open project. Views menu, to create and manage the project’s data views without opening its Views panel. Saved Workspaces menu and toggles at the top right of the browser window, to save and apply user-defined workspaces, and show or hide the panels of a workspace. For specific workflows that focus or limit user access to tools and features, you can Configure User-defined Project Workspaces within an open project. Most Kineviz menus and tools can be shown or hidden, and one or more customized panel layouts can be configured and saved as named project workspaces. Legend, on the right of the canvas, to display, select, and style nodes by Category, Tag, or a category Property name and value, and edges by Relationship or a relationship property (RelProperty) name and value. Export menu, to the right of the legend, to export the entire project or the current data view to your local system. Panel Menu on the left edge of the browser window. Kineviz functions are organized in Projects, Files, Dashboard, Query, Transform, Table, Layout, Filter, Algorithm, Agent, and Map panels. Click an item to open its panel. Additional panel menu icons are displayed when extensions such as the Kineviz Notebook and any preconfigured sandboxes are activated. Toolbar near the bottom of the window, for the available tools to Select, Edit, Arrange, and Display the graph, display Media, undo or redo History actions, or Remove data. Configurable Right-click menu of tools and operations usable on your current data selection. Right-click anywhere on the canvas to perform many graph operations without going to the toolbar or opening a panel. Navigation icons along the bottom right vertical edge, including Reset, Rotate Right and Rotate Left (by 90 degrees), Zoom _ controls, _Center To, Fly Out, and a live Minimap thumbnail view of the canvas. A Status Bar at the bottom edge, to monitor the connected database and its categories and relationships, see the number of nodes and edges on the canvas, open tables of nodes and edges, monitor Kineviz Agent status, and monitor data views. Kineviz Help menu (question icon) at the bottom of the left panel menu, to display information about the current Kineviz version. User account menu at the bottom left, to show Kineviz information, switch to another project, edit the project theme and language, open the administrator portal, or log out. Query/Search bar Use the Query bar (or enter Cmd + K) to Enter a no-code Query for data from a connected or internal graph database. Perform full-text Search of property values on indexed data in the database, or the data on the project canvas. No-code graph Query Click in the Query bar (or enter Cmd + K) for a query dropdown menu to build and run a no-code visual query on the connected graph database. Once you have data on the canvas, you can optionally use no-code Expand with Relationships from the toolbar icon or right-click menu to query for additional nodes connected through the defined relationships you select. Full-text Search The search bar at the top left also enables full-text search. You can either: Search the indexed properties in a connected database, and import the results to the project, or Search data already on the canvas. Click Configure Search Index icon to open a dialog to index the database properties available for search. Search results are listed by category below the search bar. Click a single node or a group of nodes in the search results to either: Import the data from the database, or Select and center the graph on the nodes already on the canvas. Project / View Menu Use the split Project / View menu at the top center of the canvas to manage projects and views from within an open project. Project Menu With the canvas Project menu, you can create and manage projects without returning to the Kineviz home page. You can: Add or remove a project from Favorites Edit, Clone, Export, Share, Transfer ownership, and Delete the currently open project. Create and open a new project, or select All Projects to return to the Kineviz home page. Switch to another project by selecting it on the dropdown menu of Recent Projects. View Menu With the canvas View menu, you can save and manage views in the current project without opening the Project > Views panel. You can: Create a New view. Save the current graph on the canvas to the current view, or Save As a different view. Rename or *Duplicate the current view. Share the view with another user. Export the current view as a .graphxr file. Delete the current view. Load a saved view from the Views in the this project dropdown menu. . Legend The legend at the upper right corner of the canvas provides selectable lists of nodes or edges by Category, Relationship, Tag, Property (i.e. properties defined on Categories), or RelProperty (i.e. properties defined on Relationships). Each list bubble displays: The entity label (for a category, relationship, or tag) or property value (for a property) Number of currently selected nodes or edges with that label or value Total number of nodes or edges with that label or value Use the legend lists to: Review the number of nodes of each category, tag, property (or edges of each relationship), and the number in the current selection. Click a list item to select all its nodes (or edges). Use ctrl-left click to select multiple items, and the mouse wheel or scroll gesture to scroll a long list. Click the colored dot next to a list item to style nodes and edges: For a category, you can set Color, an Icon, and select properties to be used for one or more Captions, an Avatar url, and relative node Size (based on a property value). For a relationship, you can set the Color, and select properties for Captions and Bind Width (relative width of the edge based on a property value). + + * For a listed property value or tag, you can set a *Color and Icon. Export Menu Use the Export menu to the right of the legend to download: The entire project, including its internal database and data views, as a .graphxrproject file. Tthe current data view as a CSV or Excel archive, .graphxr file, .png screenshot, or SVG file. Panel menu The Panel menu on the left edge of the canvas displays icons to open panels (and their tabbed subpanels) organized by major function. You can: Click an icon to display its panel. Click the menu’s arrow icon to show or dismiss text labels for each icon. The Panel menu is configurable. You can click + drag an icon to change the order on the menu. You can also show or hide most panels and extensions, either through Settings > UI Configuration or Project > Extensions. Project panel Project opens sub-panels to manage a project’s data views, review graph entities, set overall display preferences, manage the datastore, and access extensions: Views, to display data views saved to the server, to save, update, select, and annotate views, and to load a data view to the project space. Category and Relationship, to review defined graph entities, pull specific types of nodes or edges from a connected database and set display options for entities and their properties. Settings, to set display options for project theme and light/dark mode, nodes, edges and captions, set the project UI Configuration, show or hide Snapshot, History, Quick Info, and Show recent views on the empty canvas, Clean Unused Configuration (for Categories and Relationships), and edit the project description and its API Secrets. Data Store, for Utilities to Import data, Export the project or its data views, Save Template based on the view on canvas, show and edit the current database Schema, or Hydrate IDs of the graph on the canvas. In the Data Store section, you can review details for the connected database, create a new instance, Save Canvas to KoreDB, Upload KoreDB ZIP, Export Database, and Empty or Delete the database. Extensions, to import and access Kineviz extensions, either in the panel, or in the Admin portal. Grove Links, to manage access to Kineviz notebooks available to the project. Files panel Files opens a panel to manage Project Files, including those for Kineviz Agent, Grove, Reports, any imported files (CSV, JSON, Excel, .png, .md, etc.), and the database (if any). Dashboard panel Dashboard opens the panel for creating and displaying Kineviz dashboards available to the project. You can: Create and Save a New dashboard. Search existing dashboards by name and/or show only those marked as Favorites. Import a dashboard .json file by drag and drop or by navigating to it on your system. Query panel Query opens sub-panels to enter and save a Cypher or GQL Query on a connected database, to query SQL databases (MySQL, MSSQL, PostgreSQL, or ElasticSearch), CSV/Excel files, and JSON files. The SQL and CSV tabs include the Kineviz Mapping Editor to map data in flat files or SQL tables to a graph model. Transform panel Transform opens sub-panels for operations to transform graph data directly in GraphXR. Transform sub-panels include: Formula, to execute functions similar to formulas in Excel and SQL or functions in MapReduce frameworks. You can run formulas to add information from one column of data to another, or to modify data formats. Extract, to define a new category (and its properties) and relationship from an existing category, and extract new nodes and edges based upon it. Aggregate, to collect properties from a starting node’s neighboring edges and nodes, apply a calculation, and write the result to the starting node as a property. This makes it possible to simplify a graph, yet retain key information about its original complexity. Merge, to combine two nodes with matching properties into a single node. Link, to connect nodes with the same property values. This can be used to bring two different data sets together and also to draw explicit connections among nodes of the same type. Shortcut, to connect two nodes that share a common neighbor with a new link. Connector, to provide access to external applications for enhancing data. Table panel Table open live searchable tables of nodes and edges by Category or Relationship. You can rename categories and relationships on the fly, select, sort, edit, and reformat data, select (mark) data in the graph on the canvas, and export data as a CSV or Excel archive. Layout panel Layout opens Force, Parametric, Geometric , and Gizmo sub-panels for applying detailed layouts to all or part of the data on the canvas. Most layout options are also available from the Quick layout toolbar or right-click menu. The Gizmo is a tool to rotate and scale all or part of the graph directly on the canvas. Its tab in the Layout panel lets you specify the rotation axes that appear, or enter and apply numerical values to move, rotate, and scale a selection (similar to those you can enter in the Layout panel). Filter panel Filter opens a panel to filter and select data by multiple Node or Edge property values. You can filter on numerical property values including date-time and latitude/longitude, as well as categorical(text string) property values. Agent panel Agent opens a panel to engage with and manage the Kineviz Agent, a built-in AI assistant for working with graph data in a Kineviz project. Algorithm panel Algorithm opens GraphXR’s Path Finding, Centrality, Community Detection, and SNA (Social Network Analysis) graph algorithm library. Centrality, Community Detection, and some SNA results are added to nodes as a property value. Map panel Map opens a panel to drop nodes with latitude and longitude coordinates on a world map. Map controls and settings are provided to search map locations, set map boundaries and orientation, and choose a map server (default choices are MapBox, Open Street Maps, and Google Maps). Toolbar The Toolbar near the bottom of the window displays available one-click tools to Select, Edit, Arrange, and Display graph nodes and edges, undo or redo History actions, display Media, or Remove data. As you narrow the browser window, toolbar sections are responsively arranged in two (or more) rows. A Media section appears in the toolbar only when a selected node includes an image web link. Remove In the Remove toolbar section: Clear. Removes all data from the canvas. Delete. Deletes selected nodes and edges. History In the History toolbar section: Undo and Redo. Reverts or restores recent actions. For a list of actions that can be undone, enter Ctrl+Shift+H to open the History window. Display In the Display toolbar section: 3D/2D. Toggles between a 2- and 3- dimensional rendering of data on the canvas. Quick Info. Toggles between turning on and off Quick Info rollovers for nodes and edges. Enlarge Avatar. Enlarges the avatar image (if any) displayed on nodes. Annotate. Opens the dockable Annotate pane, and toggles it between Editing and Navigating states. Hide Selection. Hides selected nodes and edges temporarily. Un-Hide Selection. Restores all hidden nodes and edges to the canvas and de-selects them. When all nodes or edges of a category or relationship are hidden, the information bubble in the legend is faded out and a line drawn through the label. Take Screenshot. Downloads a .png screenshot of the canvas, without panels or the toolbar. Explain my canvas. Summarizes the current view using the Kineviz Agent: the node labels, number of nodes and edges, and a Takeaway summary. You can Copy the text, take a Screenshot with explanation, and/or click Continue in Agent to open the thread in the Agent panel. Arrange In the Arrange toolbar section: Quick Layout. Displays a menu to lay out selected data in Line, Grid, Cube, Circle, Sphere, Spiral, or Spring layouts, or to create a hierarchical Tree or Ring layout around selected nodes. Additional layout options include: Scale, for a slider control to expand or contract the layout Untangle, to apply curved edges and reduce crossed edges in the layout. Sort By menu, to sort the nodes in a layout by a property value. Force Layout. Toggles between turning on and off a force-directed physics layout. Pin or UnPin nodes. Toggles between pinning nodes to a location in the canvas space, and releasing nodes from being pinned. The badge on the icon shows how many nodes are currently pinned. Gizmo. Displays a tool to rotate any selection of nodes in x-, y- , or z- direction, and to expand or contract the scale independently along x-, y-, or z axes. Gizmo settings. Opens the Layout > Gizmo tab to enter settings and numerical values for rotation and scaling. Collect Nodes. Collects nodes connected to selected nodes by only one edge, and places them in special collection nodes. The information panel for a collection lists the included nodes, and enables you to remove or add back nodes. Explode Collections. Deletes selected collection nodes and restores the collected nodes to the canvas. Edit In the Edit toolbar section: Tag. Opens the Create Tag dialog to add a user-defined to tag any set of selected nodes. Expand. Opens the Advanced Expansion dialog to query the connected database for additional nodes connected to the selected nodes through specified relationships. Add Node. Displays a dialog to define and add a single node. Add Edge. Displays a dialog to add edges between selected nodes, either with an existing relationship or by creating a new one. Media The Media toolbar section includes one tool: Link. If a url is attached to a node, click to open an in-app Browser window displaying the source image and its url. You can edit and update the url, and open the window in a new browser tab. The Media section appears only when a single node with an attached url is selected. Select In the Select toolbar section: Information. Opens a floating information pane for any selection of nodes and edges. For the entire selection, the total number of items, and the number of nodes and edges is displayed. Selection List lists each node and edge, and its category or relationship. Selection Properties lists all properties in each category or relationship for the selected entities. For an individual node or edge, its properties, neighbors, graph schema, and special styling options are displayed. Entity Properties lists the properties of the node or edge. You can add or delete properties and edit property values. For nodes only, Neighbors displays a count of nodes connected to the selected node, and includes an Expand button to display the Advanced Expansion dialog. It lets you run a no-code query on the connected database to add more nodes connected through specified relationships. For nodes only, Graph displays a live graphic of the nodes and edges in the selected data, with rollovers showing the ID and properties of each node. For nodes only, Style displays the current Color, Size, Opacity, and Icon. This lets you style the selected node independently of the styling applied in the legend, and then apply the special styling to the other nodes in the selection. Use the Copy to category button to apply the styling to all nodes of that category,and the Reset style button to reset the node style to that defined on the legend. Trace Neighbor. Displays a slider above the toolbar to highlight nodes connected through a path of the number of steps and direction you choose. Once highlighted, click Select Traced to select the nodes. Query Selection. Opens the Query bar to build a no-code query based on selected nodes. Inverse. Selects all nodes not currently selected. The badge at the upper right of the icon shows the number of currently selected nodes. Select Visible Nodes. Selects all nodes currently visible in the canvas (those not hidden using Hide Selection or by de-selecting the Visible checkbox for a category or relationship in the Project panel or the Hide icon in the legend). Right-click Context Menu A customizable floating context menu of the tools available for your current selection is available by right-clicking anywhere in the project space. Use it to navigate and edit the graph without using the toolbar or opening additional panels. The default right-click menu includes often-used options at the top level: Information, Expand, Find Path, and Delete. The Select, Actions, and Layout submenus organize related options: Layout submenu: Line, Grid, Cube, Circle, Sphere, Spiral, Tree, and Ring layouts, and options to Expand, Contract, and Rotate a layout operate on selected data, or all data if nothing is selected. Layouts are grayed out if unavailable for the data. Select submenu: All Nodes, Add to Selection, Subtract from Selection, Invert, Deselect, Floating Nodes, Leaf Nodes, Neighbor Nodes, Child Nodes, Parent Nodes, Neighbor Edges, and Connected Nodes. Actions submenu: Add Node, Add Edge, Merge Nodes, Change Category, Collect Nodes, Explode Nodes, Tag, Hide, Show Hidden, Pin, Release, Highlight Nodes, and Clear Highlights. Quick Information, the Force Layout toggle, Clear, Screenshot, Link, Gizmo, and Enlarge Avatar tools appear only in the toolbar. The following table lists functions available only in the right-click menu. The other functions in the menu are also available in the toolbar or a panel. Right-Click Menu Only Function Find Path Similar to the function in the Algorithm>Path Finding tab, but finds a path between just two selected nodes. Select > Add to Selection Mouse over an unselected node, and add the node to already selected nodes. Select > Subtract from Selection Mouse over a selected node, and de-select the node. Select > Floating Nodes Select nodes with no connecting edges. Select > Leaf Nodes Select nodes with only one connecting edge. Select > Neighbor Nodes Select nodes one hop away from selected nodes. Choose again to select nodes another hop away. One hop at a time is found and the nodes selected, not just highlighted. Select > Child Nodes_ Select nodes one forward hop away from selected nodes (as shown by the direction of the connected edge). Choose again to select nodes another hop away. Select > Parent Nodes Select nodes one reverse hop away from selected nodes (as shown by the direction of the connected edge). Choose again to select nodes another hop away. Select > Neighbor Edges Select nodes one edge away from selected nodes. Select > Connected Nodes Select nodes connected to selected edges. Actions > Merge Nodes Displays a dialog to merge any selection of nodes into one node. Actions > Change Category Displays a dialog to change the category of any selection of nodes to any other existing category or to a new category. Properties of the changed nodes not present in the target category are transferred. Actions > Highlight Nodes Adds a colored ring around a node to as a persistent highlight. Actions > Clear Highlights Clears the highlight ring on selected nodes. Actions>Change Category and Actions>Merge cannot be undone with Ctrl+Z. Before using either option, save a data View, snapshot, or .graphxr file so that you can undo a mistaken change. Navigation Icons One-click navigation icons are displayed along the lower right vertical margin of the canvas. Reset the view to the center point of the data (similar to Center To). Rotate Left or Rotate Right. Zoom In or Out, or open the slider controlling zoom percent. Center To, to zoom in on the center of the graph if no nodes are selected, or the center of a group of selected nodes, or a single selected node. Fly Out, to zoom out, automatically fit, and center the entire graph on the visible canvas. Minimap, to display a live thumbnail view of the entire graph. Click + drag on the image to reposition the entire graph (usually faster than navigating on the canvas). You cannot rotate the thumbnail image. The dockable Canvas picture-in-picture available on the Save Workspaces menu is a larger thumbnail which simply shows the graph on the canvas. You cannot manipulate it directly. Project Status Bar The status bar at the bottom of the project browser window includes status information and icons to open relevant panels or the Query bar: Flask icon, if the project is a sandbox. Database icon and type of database connected to the project (e.g. KoreDB, AlloyDB, etc.). Click to open the DataStore panel to review and manage the connected database. Number of category and relationship tables in the connected database. Click to open the Project > Category or Project > Relationship panel. Search icon. Click to open the no-code Query Bar menu to query the connected database or search the current canvas. Number of nodes and edges currently showing on the canvas. Table icon. Click to open the Table panel and review properties of nodes and edges on the canvas. Agent icon, with the number of Agent chat threads currently running. Click to open the Agent panel. Views (total number of views). Click to open the Views panel. A Saved or Unsaved status flag for data currently on the canvas. About Kineviz The Help (question mark) icon on the left menu displays Kineviz version and release information, and provides links to the Kineviz Help Center, Terms of Service, and Experimental Features available in the release. About on the user account menu display the same information. User account menu The user account (person) icon displays a menu to show information, switch to another project, edit the project theme and language, open the administrator portal, or log out. Home. Return to the Projects home page. Recent Projects. Switch to another existing project, or Create New Project. Theme. Choose Light or Dark mode, or Match Theme to match the theme to the browser setting. Language. Choose a different UI language (defaults are English, Chinese, or Spanish). Shortcuts. Display a quick reference card of desktop shortcut keys. See Shortcut Keys Reference. About. Current Kineviz version and release information. The Help (question mark) icon above the user account menu displays the same dialog. Admin. Open the Administrator panel (if available to your user account). Current logged in user account ID. Logout. Log out of Kineviz.