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About GraphXR Explorer 
GraphXR Explorer for Spanner provides property graph visualization and analytics  in a 
collaborative workspace. In minutes and with no need to replicate or move data, you 
can securely connect Spanner Graph to a GraphXR project, build and run graph queries, 
and explore a visual graph. 

Before you begin… 
Before you can use GraphXR Explorer, you need: 
●​ A Google Cloud Spanner account 
●​ A Spanner database and Spanner Graph property graph database based on it.​

Note: If you want to try SpannerGraph and don’t yet have databases set up 
already, you can start with Spanner demo data available for free trial here.  

Connect to Spanner Graph 
To connect GraphXR Explorer securely to a specific Spanner Graph database, you: 
●​ Launch and Deploy GraphXR Explorer from the GCP Marketplace. 
●​ Login to GraphXR Explorer, and connect to your GCP Spanner deployment: 

○​ Create and upload a Service Account Key that authorizes the connection 
○​ Review database connection details for accuracy  

Launch and Deploy from GCP Marketplace 
1.​ On the Google Cloud Marketplace, open the GraphXR Explorer page. 
2.​ Launch and configure a GraphXR Explorer deployment 

a.​ Click Launch to configure your deployment. ​
The GraphXR Explorer for Spanner deployment page opens.  

b.​ Enter a Deployment name 
c.​ Under Deployment Service Account, click New Account.​

This creates a new Service Account with three default roles. Enter: 
i.​ Service account name 
ii.​ Service account ID  
iii.​ Service account description 
iv.​ Zone (us-central-c) 
v.​ Under Firewall, click Allow HTTP and Allow HTTPS checkboxes. 

d.​ Click Deploy.​
On the deployment page, deployment progress is indicated under Solution 
Deployments. This may take several minutes. When finished,   Resources 
and Details tabs display details for the deployment.  

3.​ Open the deployment Details tab, and scroll down to Outputs: 
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a.​ On Admin Password, click the Copy Link icon. You’ll need this to log in to 
GraphXR Explorer. 

b.​ Click Site Url to open the GraphXR Explorer Login page. 

Log in and connect to Spanner Graph 
 You’ll now log in to GraphXR Explorer and use its connection wizard to: 
●​ Create and upload a Service Account Key that authorizes the connection 
●​ Review database connection details for accuracy ​

 
1.​ In the GraphXR Explorer login, enter your userID and password and click Login. 
2.​ Follow steps in the connection wizard to connect to your Spanner Graph project 

and database.​

 
a.​ Upload Service Account. The wizard provides a connection to your Google 

Cloud account, and lists 5 steps to connect to Spanner:  
i.​ Visit the  Google Cloud Console Service Accounts page. Here you 

select your project to open the service accounts page. 
ii.​ Create a new service account (or select an existing one). ​

Click Create Service Account, and enter a name, ID, and 
description. Click Create and Continue. 

iii.​ Assign the following roles:  Under Permissions, add  Cloud Spanner 
API Service Agent, Cloud Spanner Database Reader, and Cloud 
Spanner Viewer roles, and click Continue.​
Optionally, specify Principals with access (no need to here). Click 
Done to create the service account and return to the Service 
accounts page. Now we’ll create the key file we need. 
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iv.​ Create and download the JSON key file.  
1.​ Under the correct service account, click the 3 dots at the far 

right and select Manage Keys from the dropdown menu. 
2.​ In the Keys page, click Add key and select Create new key. 
3.​ Select JSON, and click Create. ​

The JSON key file is downloaded to your system. 
v.​ Upload the key file (drag it to the upload location in the GraphXR 

Explorer wizard, then click Next. 
b.​ Database Configuration: The Instance, Database, and Graph Database 

name should be automatically filled out. Review, and click Done.​

 
GraphXR Explorer creates and opens a project connected to the specified 
SpannerGraph database. The project canvas is empty when it’s opened.  
You’re now ready to begin exploring the graph. To do that quickly, click Search to use 
the point-and-click query builder available in the project search bar. ​

​
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Property Graphs in GraphXR 
Here’s a brief look at what a property graph is and how its elements are rendered in 
GraphXR. A property graph consists of 
●​ Nodes labeled with a specific category, rendered as circles.  
●​ Edges labeled with a specific relationship, a source node ID and a destination 

node ID. An edge is rendered as a line connecting two nodes. Unconnected 
(floating) nodes can exist; unconnected edges cannot. 

●​ Properties, key-value pairs consisting of a property name and its property value, 
labeled with a specific category or relationship, and associated with a specific node 
or edge.  A node or edge can include as many properties as desired. ​
For example, the  selected node of the Book category shown below includes author, 
published, series, and title  properties, each with its property value.​
In practice, a property graph is often modeled so that nodes (or edges) of the same 
category (or relationship) include the same set of properties, but it is not required. ​

 
To inspect and work with properties in GraphXR you can: 
●​ Double-click a node or edge (or right-click and select Information) to display the 

Information panel, which includes an editable list of properties and their values. 
●​ Go to the Legend and click Property (or RelProp) to see the selectable list of node 

(or edge) properties and their unique values.  
●​ Open a Table to view properties for the nodes (or edges) of a Category (or 

Relationship). 
●​ Set property values as captions. In the example above, Character, Author, and 

Book nodes and APPEARS_IN edges are all captioned with property values. ​
​
TIP ​ If necessary, you can encrypt captions or other property values​
              displayed on the graph. To toggle between encrypted and decrypted​
               property values, use the shortcut shift+E.   
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The Project Workspace 
The project is a virtual 3D workspace. The graph is rendered as a view on the project 
canvas with nodes (as circles) connected by edges (as lines). 
The workspace provides the tools and functions needed to navigate, select, filter, 
inspect, lay out, save, and share graph views: 

 
A.​ Search Bar to query the connected database, or search the graph on the canvas. 
B.​ View menu to save the current graph as a view, or load or share a saved view. 
C.​ Legend and list at the upper right to see and select the number of nodes or edges 

of each category or relationship or the number of nodes or edges with specific 
property values, and how many of each are currently selected on the canvas.​
- Click an item to select nodes and/or  edges.​
- Style categories, relationships, and properties  with color and icons, and set​
  captions, relative node size, or edge bind width based on property values. 

D.​ Panels for detailed Project, Query, Table, Layout, and Filter  functions. Click a 
menu icon on the left edge of the project to open a panel. ​
- Project: Views, Category, Relationship, Settings sub-panels.​
- Query: Enter and run GQL or SQL queries.​
- Table: Tables of nodes by Category, or edges by Relationship​
- Layout: Fine control of the default force-directed layout.​
- Filter: Filter and select by node or edge property value. 

E.​ Contextual Toolbar along the bottom of the canvas with one-click icons for graph 
selection, navigation, layout, and information. Items found only on the toolbar are: 
Select Visible, Hide, Show Hidden, CenterTo, FlyOut, Quick Info, and 2D/3D toggle.​
Other toolbar actions are also available on the right-click menu.   

F.​ Right-click menu for often-used Expand, Find Path, basic Layout, Select, and 
Action functions, so that you need not go to the toolbar or open a panel.  

G.​  Shortcut  reference to the mouse + keyboard controls for navigation and selection.   
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No-code Query from Spanner Graph  
To use a no-code query to deliver data from SpannerGraph: 
●​ Build and run a visual query in the project query/search bar  
●​ Expand with relationships (with at least one node on the project canvas) 

Query/Search Bar 
With the no-code query builder in the project search bar, it’s fast and easy to build a 
graph pattern and import matching nodes and edges from the database. Instead of 
writing a GQL query on your own, just select available categories, relationships and 
properties from the dropdown menu. 
1.​ Click Search (or click in the project search bar at the upper left of the canvas) to see 

the query builder dropdown menu. 
2.​ Click to select a category from the menu. Optionally, select and specify one or 

more property values. ​

​
The menu then shows the relationships connected to that category.  

3.​ Select a relationship, and the categories connected to it appear.​
Here we query a database of books by Lewis Carroll to return Character nodes 
with a name property containing Tweedle, connected through APPEARS_IN edges to 
any Book node.​

 
4.​ Click the search icon at the right end of the search bar to run the query.​

Matching nodes and edges are displayed on the project canvas.​

​
You can continue to query for additional patterns. A message is displayed when all 
the data matching a query have been loaded.    
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Expand with Relationships 
Once at least one node is on the canvas, you can use Expand to select one or more 
nodes and query for additional nodes connected through the relationships you choose.  

1.​ Select the node (or nodes) to expand on. 
2.​ Right-click, and choose Expand from the menu.​

 
3.​ Choose All, or just the relationship you want. For more detailed control,  you can 

choose Advanced Expansion from the menu or the Expand icon on the toolbar.​

 

GQL or SQL Query 
Open the Query panel to enter and run a GQL or SQL query, and to save your queries 
in the project.  ​

 
1.​ Choose the query language (GQL or SQL) from the dropdown menu. 
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2.​ Enter a query in the window below.​
OR​
Click Collection list (dropdown arrow icon) to show the default query that’s provided 
and any saved queries. Click to add a query to the query window, where you can 
(optionally) edit it and then run it.​

 
3.​ Click Run (rightmost arrow icon) to query the database. 
4.​ You can click Add to collection (plus icon) to save a new or edited query.  
5.​ In the Alias Name dialog, enter a descriptive name for the query and click Confirm.​

​
Saved queries persist in the project (i.e. when you log out and log back in). 

Full-text search for specific nodes 
Full-text search is available for property values of the nodes on the project canvas. ​
NOTE: Full-text search on the database is available only if it has been implemented and 
indexed.  
1.​ In the search bar, choose Canvas on the dropdown selector at the far left.  
2.​ Enter search text (e.g. Alice) 
3.​ Click the search icon to see a list of all nodes that include that text as a property value.​

​
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Style nodes and edges 
In the Legend list, click the colored dot, line, or paintbrush icon next to a list item to 
display the Style Setting dialog for that set of nodes or edges. Tabs in the dialog let you 
select a Color and Icon for nodes, and select properties that supply Avatar image urls, 
relative node Size or edge Bind Width, and Captions on nodes or edges. 

Style a Category or Property 
In the Legend, click Category or Property, then the paintbrush or dot next to a list item. ​

 
○​ Color: Use the color picker, click a color spot on the default color palette, or 

select a custom color palette and choose a color from it.  
○​ Icon: Choose an icon set from the menu, or enter a search for an icon. 

Then click to select the icon you want.​

  
○​ Avatar: Choose a property that includes a url for an avatar image. 
○​ Size: Choose a property with numerical values to set relative node size.  
○​ Caption: Choose one or more properties to label the nodes. Multiple 

captions are displayed in the order you select.​
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Style a Relationship 
●​ Click Relationship in the legend, then line next to an item in the relationship list. 

○​ Color: Use the color picker to select a color. 
○​ Bind Width: Choose a  property with numerical values to set the bind width 

of edges. 
○​ Caption: Choose one or more properties to label the edges.​

​
 NOTE: An initial graph model may not include properties on relationships.​
​
Often, the relationship label (or name)  is the most useful text caption for 
an edge.  To display it on all edges, open the Project>Settings panel and 
click the Show Relationship Name checkbox.​

 

Adjust overall display of nodes and edges 
Open the Project>Settings panel for options to set overall display, including: 
●​ Theme selector to choose dark or light mode, 
●​ Hide Pin Icon checkbox to show or hide the pin icons on all nodes, 
●​ Use Curve Line checkbox to display edges as either straight or curved lines,  
●​ Hide Arrow checkbox to show or hide the directional arrowheads on all edges. ​

 

________________________________________________________________________________________________
​ ​ ​ ​ ​ ​ © 2025 Kineviz, Inc. ​ ​ ​ ​    ​                 10 



GraphXR Explorer QuickStart Guide 
_________________________________________________________________________________________________________________ 

●​ The Advanced Settings dropdown provides additional control of visual display: 
○​ Checkboxes to display Dash Line, Blend Edges, Auto Caption, Truncate 

Captions, and Alternate Caption Rendering (for faster display of captions 
on large data sets). 

○​ Sliders for scaling overall Edge Width, Node Size and Caption Size, and for 
setting Fog Density in the 3D rendering on the canvas. 

○​ Node Caption Position menu (right, left, bottom left, bottom center, top 
left, top center, or vertical), 

○​ Icon Mode menu for display of icons (background transparent, icon 
transparent, or mix color), 
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Navigate and Focus the Graph 
You can navigate the graph, and select, inspect, edit, and focus on all or part of it using: 

●​ Navigation with manual mouse and keyboard controls to Pan, Zoom, and move 
the graph, and one-click Fly Out and CenterTo icons in the toolbar. 

●​ Selection with manual mouse and keyboard controls 
●​ Selection and actions based on node or edge criteria including:  

○​ Legend selection by category, relationship, or property value 
○​ Selecting and inverting using the right-click Select menu 
○​ Toolbar-only selection and navigation options 
○​ Isolating a path using right-click Find Path or toolbar Trace neighbor options 
○​ Filter nodes on property values 
○​ Open a Table to select and highlight nodes on the canvas  

Mouse and Keyboard controls 
Mouse and keyboard controls are provided to navigate the whole graph or a selection 
of it, and to select nodes and edges manually. Often-used controls include:   
●​ Navigate the graph:  

○​ Pan (left mouse click-drag) 
○​ Zoom in and out (mouse wheel) 
○​ Move Stepwise (arrow key-click  right, left, up or down) 
○​ Move a selection (left mouse click-drag) 
TIP: Click the toolbar Fly Out (alt+shift-R) to fit the entire graph on the canvas,​
        or CenterTo (c + left mouse double click) to center the graph on a selection ​
        (or the whole graph). 

●​ Select nodes and edges:  
○​ Select one node or edge (left mouse click) 
○​ Select multiple nodes and edges (shift+left mouse click-drag) 
○​ Add a node to a selection(ctrl-left mouse click) 
○​ Subtract a node from a selection (alt+left mouse click) 
○​ Select all nodes (ctrl-A) or Deselect all nodes (alt+A or double click empty space) 
○​ Invert a selection ( I ) 
○​ Undo (ctrl+Z) and Redo(ctrl+Y), or show a History pane (ctrl-shift+H)to revert to 

a former state of the graph.  
Once you have selected nodes and edges,  you can:  
●​ Move the selection away from unselected nodes (left mouse click-drag)   
●​ Refine your selection further using toolbar icons (Invert, Hide, Trace 

Neighbor+Select Visible), and/or right-click Select menu options.  
●​ Lay out selected nodes in one click with the right-click Layout or toolbar Quick 

Layout menu, which provide various geometric or hierarchical layouts. 
 
To display shortcut information within GraphXR Explorer: 
●​ On the project menu click the Kineviz logo at the lower left, and choose Shortcut.  ​
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The following table shows all the current mouse-keyboard shortcuts.  

Shortcut Keys for Navigation, Selection, and Editing ​
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Select using the Legend 
Use the Legend to show and select all the nodes or edges of one or more categories or 
relationships, or unique property values for either categories (Property) or 
relationships (RelProperty).  
The legend list bubble shows the total number of nodes (or edges), and the number 
that are currently selected. ​

 

Select by Category or Relationship 

To select by Category or Relationship: 
1.​ Click the appropriate section in the legend (Category and/or Relationship) to show 

the list of items. You can show both at once. 
2.​  Click a list bubble to select its items on the canvas. ​

​
Or Ctrl+Click to select more than one list item.​
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Select by Property Value 

To select by a category (or relationship) property value: 
1.​ Click the appropriate section in the legend (Property or RelProperty). 
2.​ In the dropdown menus below the legend, select a category or relationship and the 

property you want (e.g. the Horse category, and its Color_Sex_Age property). ​
The list displays unique values for that property, and the number of nodes (or 
edges) that have that property value. 

3.​  Click a list bubble, or ctrl-click to select one or more list items. ​

​
The selected nodes are highlighted, and you can now work with the selection. ​
For example, left-click drag to move the nodes  to another part of canvas, invert 
and hide or delete the inverted selection, apply a layout, etc. 

Right-click Selection and Action  
The right-click Select and Actions menus provide efficient ways to select and isolate 
graph entities that you want to focus on, hide temporarily, or delete from the canvas. 

Select nodes and edges by connection type 

1.​ Except for Floating nodes and Leaf nodes, you must first select one or more nodes 
or edges.  

2.​ Right-click anywhere on the project canvas, and on the Select submenu,  
choose from the following types of nodes or edges: 

●​ Floating nodes, to select all nodes that have no connecting edges. 
●​ Leaf nodes, to select all nodes connected to only one other node. 
●​ Neighbor nodes, to select nodes connected through one edge to the 

selected node(s). 
●​ Parent or Child nodes, to select nodes connected to the selected node(s) by 

a directed relationship, indicated by the arrowhead on the edge pointing 
from a parent to a child node.    

●​ Neighbor Edges, to select all edges connected to the selected node(s) 
●​ Connected nodes, to select nodes connected to the selected edge(s)  

​ The nodes or edges you first selected are de-selected and those with the chosen​
​ connection type are selected and highlighted.   
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Add (or subtract) connection types to a selection 

You can repeat and combine Select menu options to select the specific subgraph you 
want.  For example, you can choose Neighbor nodes several times to add nodes a 
specific number of hops away from an  initial selection.   
To add  to a current selection: 

●​ Right click, press ctrl, and choose from the Select menu. 
To subtract from a current selection:  

●​ Right-click, press alt, and choose from the Select menu. 

Invert a selection 

Inverting a selection is often used to focus on a subgraph by hiding the other nodes 
temporarily or deleting them. 

●​ With nodes selected, right-click, choose Select>Invert. ​
You can now go to the toolbar and click Hide Selection, or Delete. 

Toolbar-only functions  
Various selection, navigation, and layout options are available only through toolbar 
icons. These (and the shortcut key if any) are: 
●​ Selection 

○​ Trace Neighbor 
○​ Select Visible 
○​ Hide Selection and Show Hidden 
○​ Delete a selection (delete key) 
○​ Clear the graph (ctrl-shift+C) 

●​ Navigation 
○​ CenterTo, to center the graph on one or more selected nodes. (c+left mouse 

double click) 
○​ FlyOut, to fit the entire graph on the canvas. (alt+shift-R) 

●​ Display and Layout 
○​ 2D/3D toggle, to switch between 3D and a flat 2D rendering of the graph, useful 

for preparing 2D visualizations for reports and presentations. 
○​ Enable/Disable Force Layout toggle, to turn default force layout off or on.  
○​ Quick information toggle, to control display of a simplified information rollover 

for a node or edge.   
NOTE​ Pin/Release, Expand, Quick Layout, and Information functions​
​ ​ are also available through the right-click menu and shortcut keys.  

Find Paths and Analyze Connection 
Paths between nodes in a graph can reveal unsuspected connections that are 
otherwise difficult to bring to the surface. In GraphXR Explorer, you can 
●​ Trace neighbor nodes a specific number of hops away from a selection, and isolate 

the path.  
●​ Find a path, if one exists, between two nodes. 
●​ Measure connectedness of nodes via the Degree Centrality algorithm. 
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Trace and Isolate a path 

Use the toolbar Trace Neighbor and Select Visible icons to highlight and select  paths 
through the graph. 
1.​ Select the initial nodes, and click Trace Neighbor.​

A slider displays the total number of hops  to other parts of the graph.  
2.​ Move the slider to the number of hops (connections) you want to trace.​

The connected nodes are highlighted, but not selected.​

 
3.​ Click the  Select Visible icon to select the highlighted nodes.​

 
4.​ Click the Inverse icon to invert the selection. 
5.​ Click the Hide Selection (or Delete) icon to remove the nodes not on the paths.​
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Find a path between two nodes 

Use the right-click Find Path item to find and select the path between two nodes. 
1.​ Click to select a node, then ctrl-click a second node to add it.  
2.​ Right-click, and select Find Path.​

The path, if any, is highlighted and selected.​

 
3.​ On the toolbar click the Inverse icon to invert the selection. (Or right click and 

choose Select>Invert) 
4.​ Click the Hide Selection (or Delete) icon to remove the nodes not on the paths 

from the canvas.​

 

Measure degree centrality 

Degree Centrality is a graph algorithm that measures the connectedness of each node 
by counting the number of edges it is connected to.  
●​ Use the keyboard shortcut: ctrl-shift+D ​

The degree centrality algorithm is run on the entire graph currently shown on the 
project canvas.​
 The result  is added to each node as a new degree property with the edge count as 
its numerical property value.  ​
NOTE ​ If part of the graph is currently hidden, the hidden nodes will have a degree ​
​ property with a value of zero. 

To work with the new property, you can select by property value in the legend, add it as 
a caption to nodes, filter on its value, inspect it in tables, and so on. 
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Filter nodes  
Open the Filter panel to create multiple independent filters that filter on node or edge  
property values.   
1.​ Select properties to filter one or more Node Property or Edge Property values (e.g. 

OrderDate and PriceUSD).​

 
2.​ A continuous filter with a slider control is provided for numeric, date-time, or 

lat-long property values. Use it to: 
○​ Manually scrub through continuous property values, or use playback 

controls to filter in either direction, or in a continuous loop.  
○​ Set the values to be filtered (e.g. a date or specific price point).  
○​ Set a range of values and click the Lock Range checkbox. 
○​ Click the Chart checkbox to display a bar chart of filtered values. 

A discrete filter is provided for filtering strings or text.  Use it to:  
○​ Enter text search (including wildcard or regex patterns) to select property 

values to be included.  
○​ Click the checkbox next to a property value to include it. By default, all 

values are selected. 
3.​ If your filter retains the data you want, you can close the filter panel and begin 

working with it, or save it as a view.​
OR ​
If you filtered out the data you want, click Select Visible in the Filter panel or 
toolbar, then delete the filter(s) to show all the data. ​
The data you don’t want is still selected, so in the toolbar, click Invert and then 
Hide or Delete.​
NOTE​ Filters persist when you close the panel, until you exit the project. This lets ​
​ you work with a filtered subgraph. To return to the full graph, delete the ​
             filters that are in effect. 
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Explore and select from a Table 
You can use  tables to inspect  properties associated with each category or relationship, 
and to select and highlight nodes on the canvas. ​

 
●​ Open the Table panel, choose  Category or Relationship, and click a label to open a 

table of those nodes or edges. You can 
○​ Click a table item to center the node or edge on the canvas.  
○​ Click Select All to select all the items of that type on the canvas.​

NOTE    The table shows selected nodes (or edges), or all items if nothing is​
​         selected. 

●​ Click Enhanced Table to open an editable table where you can: 
○​ Click the Arrow icon at the upper right to pop the table out into a separate 

browser window 
○​ Select and mark (highlight) nodes on the canvas. 

 
○​ You can also: 

■​ Edit Category and Relationship names 
■​ Edit and delete the property values in the table 
■​ Search the table 
■​ Export data as CSV or Excel 
■​ Delete data on the graph 

________________________________________________________________________________________________
​ ​ ​ ​ ​ ​ © 2025 Kineviz, Inc. ​ ​ ​ ​    ​                 20 



GraphXR Explorer QuickStart Guide 
_________________________________________________________________________________________________________________ 

Lay out the Graph  
GraphXR Explorer provides a variety of quick layouts that help you focus on subgraphs 
and key insights, and communicate results effectively. You can apply any layout to any 
selection of nodes, or to the entire graph. 
TIP​ ​ To lay out results in 2D for reports or presentation, click the 2D/3D toggle​
​ ​ icon in the toolbar. You may also want to switch to light mode. In​
               ​ Project>Settings, click the Theme icon to toggle between modes.  

Geometric Layouts 

1.​ Select nodes to lay out using any selection method. 
2.​ Right-click>Layout (or click the toolbar Quick Layout icon) and choose a ​

Line, Grid, Cube, Circle, Spiral, Sphere, or Spring layout.​
NOTE ​ If you are in 2D mode, the 3D layout options (Cube, Spiral, Sphere, and​
​  Spring) will be grayed out. 

3.​ The layout is displayed in a default location on the canvas. With the nodes still 
selected, move them on the canvas (left click-drag) to where you want them.  

4.​ Optionally, right-click and choose Layout>Expand or Layout>Contract to expand 
(or contract) the selected layout, or Rotate to rotate the layout counterclockwise​
 90 degrees.​

 

Hierarchical Ring or Tree Layouts 

Ring or Tree layouts arrange nodes in hierarchical levels around selected central nodes. 
Most often, you’ll want to select nodes of a particular category for the centers, but any 
selection (or none) works. 
When choosing a hierarchical layout, consider how many levels of connection there are 
in the graph, and how many connections the central nodes have. Generally, tree layouts 
are easier to interpret if most of the central nodes have a small number of connections. 
When central nodes have many connections, a ring layout is usually a better choice.  
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To apply a ring or tree hierarchy: 
1.​ Select the nodes to be the centers of the hierarchy. 
2.​ Optionally, apply a geometric layout, such as a line, grid, or circle to the selection, 

and orient it so that the ring or tree layout can be easily seen. ​
You may need to expand (or contract) the selected geometric layout 
(Layout>Expand or Layout>Contract) to make enough room. 

3.​ Right click and select Layout>Tree​

 ​
OR​
Right click and select Layout>Ring​

  ​
Nodes one hop away from the central nodes are arranged in the first level, those 
two hops away are at the second level, and so on. ​
​
TIP​ A ring or tree layout is flat, but in 3D mode, you can move nodes up or​
​  down on the canvas. Doing so can help make complicated connections​
​  more visible.​
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Pin or Release nodes 

Nodes are automatically pinned to a specific spot on the canvas if you move them 
manually or apply a quick layout.  
Pinned nodes are not included when applying force layout, and you may want to pin 
some nodes to prevent them from being automatically moved, or release some or all  
pinned nodes to return that part of the graph to a default force layout. 
●​ The toolbar Pin/Release icon shows how many nodes are currently pinned. Click 

the icon to toggle between pinning and releasing all pinned nodes (or a selection)   
in one click. Released nodes are rendered in the default force layout. 

●​ A pin icon is displayed on any pinned nodes, but you can hide it if desired. Simply 
go to  Project>Settings and click the Hide Pin Icon checkbox.   

To pin selected nodes:  
1.​ Select the nodes you want to pin.  
2.​ Right click, and select Actions>Pin. 

To release selected nodes: 
1.​ Select the nodes you want to release.  
2.​ Right click, and select Actions>Release. 

Save Views  
At any time, you can save the state of the graph as a live view. This is particularly useful 
for saving 
●​ the starting point of an exploration that’s likely to go in different directions, 
●​ results of  focused analysis, and  
●​  layouts that communicate key insights.  

Saved views are displayed in the Project>Views tab.  
However, the dropdown view menu lets you create, save, share, and load views without 
opening the Project  panel.​
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Saving or loading from the view menu​
When you open the project, the canvas is empty, and the view on the menu is labeled 
Unsaved View. Once you have imported graph data or loaded a previously saved view, an 
asterisk is displayed on the menu indicating that the view has changed. ​

 

Click the dropdown view menu and choose 
●​ Save to save and replace the current view 
●​ Save As to save the current view as a new view. In the dialog, enter a descriptive 

view name and click Submit (or Cancel). 
●​ New, to clear the current graph and create a new empty view. 
●​ Choose a view from the list of the last five saved views, or click all views… at the 

bottom to choose from a list of all saved views. ​
NOTE ​ If the current view you are replacing has unsaved changes, a dialog ​
​ prompts you to Save, Save As, or Don’t Save.   

Manage Saved Views 

The Project panel and Views tab includes additional options to work with saved views. 
●​ Click the tile/list icon to display views as tiles with thumbnail images, or as a list. 
●​ Click a tile or list to load a view to the canvas.  
●​ Sort by name, date created or date modified, in ascending or descending order.​
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●​ Search for a view. Click the search icon to filter on the view name.​

 
●​ Click icons on the view tile or list to 

○​ Show and annotate view Information​

 
○​ Share a view 
○​ Delete a view 
○​ Edit a view name​

 

Share a View 
You can share a view that’s on the project canvas, or share any saved view. 

Share the view on the project canvas 

1.​ Choose Share on the view dropdown menu. 
2.​ Optionally, require authentication and enter a password. 
3.​ Click Copy Link, and send it and the password (if any) to your colleagues.    

Share a saved view 

1.​ Open the Project panel and Views tab, locate the view, and click its share icon. 
2.​ Complete steps 2 and 3 above. 
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Add GraphXR features to Explorer  
The default Explorer user interface includes the basic features needed to visualize, 
explore, and share  graph data. For even more powerful graph modeling and analysis,  
you can freely access a full range of additional GraphXR features through the Project’s  
UI Configuration panel. It’s where you select  additional GraphXR panels, toolbar items, 
and right-click menu items that will then appear in your project. Features you may want 
to add include:  
●​ Layout (Distribution and Label layouts), which let you sort nodes in your 

geometric layouts by property value. 
●​ Map, for a panel to drop nodes with lat-long property values on a world map. 
●​ Property graph modeling features 

○​ The Transform panel and its Formula, Extract, Link, Aggregate, Merge, and 
Shortcut tabs).  

○​ The Graph Composer Extension to model collections of relational tables or 
CSVs as a property graph. 

●​ The Grove Extension, for building and sharing Observable-based notebooks.​
 

An overview of each of these features is included in this guide. More detailed 
information on their use is available at the Kineviz Help Center.  

Configure your Project UI 
To change the project’s UI configuration: 
1.​ Open the Project panel and Settings tab, and click the UI Config button. 

  
2.​ UI elements are organized into functional groupings listed alphabetically (e.g., 

Algorithms, Bottom Menu, Context Menu, etc.).  Scroll down to see all  the elements.​
​
The icon next to an element indicates its current status: Disabled, Enabled on the 
Project, or Enabled on the Project and for Shared Views.​
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3.​ Click the icon next to a group or an individual element to change its status.​

 
4.​ When you are done, go to the top of the window and click Save to update the UI 

configuration and return to your project. 

Sorting by Property Value in Geometric Layouts 
Sorting or distributing nodes on the canvas by property value can greatly enhance the 
visual impact of a graph. Along with many other detailed layout controls, this capability 
is only available in the Geometric tab of the Layout panel.  
1.​ In  UI Configuration, scroll to the Layout section and click Distribution Layout  

and Label Layout). Click Save to return to the project. 
2.​ Open the Layout panel. You now see the Geometric layout tab, and its many 

options for controlling  layout of nodes on the canvas.   
3.​ To sort nodes in a layout by property value, select the nodes, and under the 

Layout section, click the Order by Property Value checkbox. 
4.​ Select a Category and  Property, and click the Ascend or Descend checkbox. 
5.​ Click a  geometric layout  (Line, Circle, etc.) to apply the layout with sorted nodes.  

NOTE: The steps are the same for the Distribution layout function.  
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Geographic Map 
The Map panel is hidden in Explorer by default. However if some of your nodes include 
lat-long property values, you’ll probably want to display them on a world map.  
1.​ In UI Configuration, scroll to the Map element and click to enable it. Click Save to 

return to the project. 
2.​ The left menu now displays the Map icon.  
3.​ Click to open the Map panel and click Show Map to drop nodes with latitude and 

longitude property values on a world map.  ​

 

Property Graph Modeling 
Explorer’s basic connection to a Spanner Graph database provides fast intuitive 
visualization and exploration of the graph as it exists in the source database. You may 
want to re-model the graph in your  project, for example to extract new categories, link 
data, simplify the graph, or add new data from various sources. You can do this using 
features in GraphXR’s Transform panel and the Graph Composer extension.  
1.​ In UI Configuration, scroll to the Extensions element and click GraphComposer 

to enable it.  
2.​ Then scroll to the Transforms section, and click to enable everything except 

Connections.  
3.​ Click Save to return to the project. The left menu now displays: 

●​ A Transforms icon. Click to open its panel and see the  Function (f(x)), Extract, 
Aggregate, Merge, Link, and Shortcut tabs. ​

________________________________________________________________________________________________
​ ​ ​ ​ ​ ​ © 2025 Kineviz, Inc. ​ ​ ​ ​    ​                 28 



GraphXR Explorer QuickStart Guide 
_________________________________________________________________________________________________________________ 

​
For information on using these features, see Transform Data documentation. 

●​ A Graph Composer icon. Click to open its panel. ​

​
You are prompted to complete a multi-step process to create mappings that 
model data from relational tables, CSVs, and other sources as a property graph, 
preview the results, and save the mappings and the modeled graph. ​
For more information, see GraphComposer documentation. 

Grove Notebook Extension 
Grove is a GraphXR extension for building repeatable workflows in an 
Observable-based notebook environment. A full-featured GraphXR API enables most 
GraphXR actions to be performed in the notebook.  
1.​ In UI Configuration, scroll to the Extensions element and click Grove to enable it. 

Click Save to return to the project. 
2.​ The left menu now displays a Grove icon. Click to open the panel. A demo 

notebook is available to provide an overview of Grove capabilities. 
For more information, see Grove documentation. 
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What if I don’t have a Spanner graph database yet? 
A Spanner Graph project and database must be created on the Google Cloud Platform 
before you can connect it to a GraphXR project. If you don’t have a database set up, 
you can sign up for a GCP account, and get a free demo database that you can use for 
up to 90 days. ​
NOTE ​ For details, see Google Cloud Spanner documentation. 
1.​ Visit GCP https://console.cloud.google.com/ 
2.​ Open the project picker to create a project, or choose an existing one. We’ll create 

a new project.​
IMPORTANT​  The project must be connected to a billing account, even though 
creating and using the demo project is free.​

 
3.​ Click the New project button.​

 
4.​ Enter a project name.​
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5.​ After creating the project, select it with the project picker.​

 
6.​ Use the search bar to find and select Spanner.​

 
7.​ Enter an Instance name, Instance ID, and choose a region. ​

(e.g. us-east4) 
8.​ Click Create free instance. 
9.​ Now go to the GCP Studio.​

 
10.​   Choose a sample query for the ECommerceGraph and try it out.​
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