You can import data in .CSV, .JSON, GraphXR’s .graphxr and .graphxrsnapshots, and many other data formats by drag and drop. Simply locate the file on your system, then drag and drop it anywhere in the project graph space.

In the Project panel and Data tab you can also click Import (for .graphxrsnapshots, .CSV, .JSON, etc. files), or Load GXRF (for .graphxr files), then navigate to the file and click to load the data.

Importing tabular data by drag and drop

When you import data that has no defined graph schema, such as a flat .CSV file, each row is imported as a node of a single default category.

For example, the following spreadsheet for a travel log with just three columns headed date, from_country, and to_country can be dropped onto the project space.

  • A node representing a single travel event is created for each row. All the nodes are assigned a single category labeled with the name of the file (i.e. COVID-19 Travel Log - Sheet1).

  • The three column headings in the file are assigned as property names: date, from_country, and to_country, and property values are entered for the respective nodes.

Starting with unconnected nodes, you can create connected graph data using GraphXR's navigation, selection, and transformation tools. In particular, the Transform panel provides powerful ways to create and/or simplify categories and properties as well as relationships.

Importing graph data by drag and drop

When you import graph data by drag and drop, such as graph data from a .JSON file, .graphxr file, or GraphXR Snapshot archive (.graphxrsnapshots file), the categories, relationships, and their properties are included. The data also retains the 3D layout, position in the graph space, and view perspective it had when it was saved.

Unlike importing .CSV or .JSON files, importing graph data from GraphXR ( .graphxr files, .graphxrsnapshots archives, or data Views) clears any data that may already be in the project space. To save data you want to retain, first go to the Project=>Data tab and choose Save GXRF or Save CSV, or Save to Neo4j, if saving to a connected database is wanted.

When a .graphxrsnapshots snapshot archive is dropped on the graph space, the Snapshots window appears. Existing data if any is replaced with one of the snapshot views.

To select a snapshot view:

  1. Click the arrow on the left edge of the Snapshots window to expand the snapshot archive and locate the snapshot you want.

  2. Click the snapshot’s cloud icon to import the data view.
    For example, the geometric layout of graph data from the Game of Thrones demo shown below was saved as a snapshot, which can now be imported into any other GraphXR project.